Текущее время: Вт авг 03, 2021 11:44 am
Часовой пояс: UTC + 1 час

Network lan was plugged in

Модераторы: Bennettest, Shawn.S@AST, sashawang, Alex Fokeev

Re: Network lan was plugged in

Сообщение maksmedia » Пн апр 26, 2021 1:15 pm

Итак, сегодня протестировал STATIC IP подключение к роутеру - тоже не помогло. Анализ логов выявил, что реконнект делается WATCHDOG по причине:

Код: Выделить всё
2021-04-26T14:52:18.043977+03:00 nimbustor kernel: [15004.987646] NETDEV WATCHDOG: eth0 (r8125): transmit queue 0 timed out
2021-04-26T14:52:18.044009+03:00 nimbustor kernel: [15004.987696] ------------[ cut here ]------------
2021-04-26T14:52:18.044015+03:00 nimbustor kernel: [15004.987709] WARNING: CPU: 3 PID: 0 at /asustor/branch3_5_2021_03_12/x64_g3/source/linux-4.14.x/net/sched/sch_generic.c:320 dev_watchdog+0xdc/0x135
2021-04-26T14:52:18.044052+03:00 nimbustor kernel: [15004.987713] Modules linked in: vboxnetadp(O) vboxnetflt(O) vboxdrv(O) xt_conntrack ipt_MASQUERADE nf_nat_masquerade_ipv4 xfrm_user xfrm_algo xt_addrtype snd_seq_midi snd_usb_audio snd_usbmidi_lib snd_rawmidi snd_seq_midi_event snd_seq snd_seq_device btusb btrtl hci_uart btqca btbcm btintel hid_magicmouse hidp des_generic rfcomm bnep bluetooth ecdh_generic cryptodev(O) usbip_host usbip_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi iscsi_scst(O) scst_vdisk(O) scst(O) nfsd lockd grace sunrpc snd_hda_codec_hdmi snd_hda_intel snd_hda_codec_realtek snd_hda_codec_generic snd_hda_codec snd_hwdep snd_hda_core snd_pcm snd_timer snd fnotify(PO) intelfb i915 drm_kms_helper sysimgblt sysfillrect syscopyarea fb_sys_fops drm isofs udf crc_itu_t sr_mod cdrom sys_stat(C) au6004t(O) asleddrv(O) quota_v2
2021-04-26T14:52:18.044061+03:00 nimbustor kernel: [15004.987816]  quota_tree iptable_filter iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat ip_tables bridge dm_crypt
2021-04-26T14:52:18.044074+03:00 nimbustor kernel: [15004.987835] CPU: 3 PID: 0 Comm: swapper/3 Tainted: P         C O    4.14.x #1
2021-04-26T14:52:18.044077+03:00 nimbustor kernel: [15004.987838] Hardware name: Insyde GeminiLake/Type2 - Board Product Name, BIOS V1.19 09/27/2018
2021-04-26T14:52:18.044078+03:00 nimbustor kernel: [15004.987842] task: ffff888276180000 task.stack: ffffc90000cf4000
2021-04-26T14:52:18.044080+03:00 nimbustor kernel: [15004.987849] RIP: 0010:dev_watchdog+0xdc/0x135
2021-04-26T14:52:18.044093+03:00 nimbustor kernel: [15004.987852] RSP: 0018:ffff88827fd83e68 EFLAGS: 00010296
2021-04-26T14:52:18.044098+03:00 nimbustor kernel: [15004.987856] RAX: 0000000000000039 RBX: ffff888271b18000 RCX: 0000000000000000
2021-04-26T14:52:18.044115+03:00 nimbustor kernel: [15004.987859] RDX: 0000000000000001 RSI: 0000000000000002 RDI: 0000000000000300
2021-04-26T14:52:18.044133+03:00 nimbustor kernel: [15004.987862] RBP: ffff88827fd83e78 R08: 0000000000000002 R09: 0000000000000000
2021-04-26T14:52:18.044138+03:00 nimbustor kernel: [15004.987881] R10: 0000000000000000 R11: 0000000000000000 R12: 0000000000000000
2021-04-26T14:52:18.044149+03:00 nimbustor kernel: [15004.987882] R13: ffff888271b18470 R14: ffff88827fd83ec0 R15: ffffffff8168ba12
2021-04-26T14:52:18.044153+03:00 nimbustor kernel: [15004.987884] FS:  0000000000000000(0000) GS:ffff88827fd80000(0000) knlGS:0000000000000000
2021-04-26T14:52:18.044155+03:00 nimbustor kernel: [15004.987886] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
2021-04-26T14:52:18.044158+03:00 nimbustor kernel: [15004.987887] CR2: 00007fc562addaf0 CR3: 000000000300a000 CR4: 00000000003426e0
2021-04-26T14:52:18.044163+03:00 nimbustor kernel: [15004.987889] Call Trace:
2021-04-26T14:52:18.044165+03:00 nimbustor kernel: [15004.987892]  <IRQ>
2021-04-26T14:52:18.044168+03:00 nimbustor kernel: [15004.987896]  ? netif_tx_unlock+0x46/0x46
2021-04-26T14:52:18.044187+03:00 nimbustor kernel: [15004.987900]  call_timer_fn.isra.21+0x1d/0x89
2021-04-26T14:52:18.044207+03:00 nimbustor kernel: [15004.987903]  __run_timers+0x134/0x17c
2021-04-26T14:52:18.044211+03:00 nimbustor kernel: [15004.987906]  ? tk_clock_read+0xc/0xe
2021-04-26T14:52:18.044228+03:00 nimbustor kernel: [15004.987908]  ? timekeeping_get_ns+0x1e/0x33
2021-04-26T14:52:18.044232+03:00 nimbustor kernel: [15004.987910]  run_timer_softirq+0x18/0x2e
2021-04-26T14:52:18.044234+03:00 nimbustor kernel: [15004.987914]  __do_softirq+0xb4/0x1c5
2021-04-26T14:52:18.044249+03:00 nimbustor kernel: [15004.987918]  irq_exit+0x69/0xac
2021-04-26T14:52:18.044253+03:00 nimbustor kernel: [15004.987921]  smp_apic_timer_interrupt+0x6e/0x83
2021-04-26T14:52:18.044268+03:00 nimbustor kernel: [15004.987923]  apic_timer_interrupt+0x8c/0xa0
2021-04-26T14:52:18.044272+03:00 nimbustor kernel: [15004.987924]  </IRQ>
2021-04-26T14:52:18.044274+03:00 nimbustor kernel: [15004.987928] RIP: 0010:cpuidle_enter_state+0xea/0x142
2021-04-26T14:52:18.044288+03:00 nimbustor kernel: [15004.987929] RSP: 0018:ffffc90000cf7e68 EFLAGS: 00000246 ORIG_RAX: ffffffffffffff10
2021-04-26T14:52:18.044293+03:00 nimbustor kernel: [15004.987931] RAX: ffff88827fd9fa80 RBX: ffff8882719d0200 RCX: 0000000000000003
2021-04-26T14:52:18.044294+03:00 nimbustor kernel: [15004.987933] RDX: 00000da59ef4ca01 RSI: fffffff8a5b4fb99 RDI: 0000000000000000
2021-04-26T14:52:18.044309+03:00 nimbustor kernel: [15004.987934] RBP: ffffc90000cf7ea8 R08: 00000000401a41a4 R09: 0000000000000d51
2021-04-26T14:52:18.044312+03:00 nimbustor kernel: [15004.987935] R10: 0000000000000d51 R11: 0000000000000001 R12: 0000000000000003
2021-04-26T14:52:18.044339+03:00 nimbustor kernel: [15004.987936] R13: 00000da59ef4ca01 R14: 0000000000000000 R15: 00000da59eb8cb9f
2021-04-26T14:52:18.044344+03:00 nimbustor kernel: [15004.987939]  ? cpuidle_enter_state+0xc4/0x142
2021-04-26T14:52:18.044346+03:00 nimbustor kernel: [15004.987942]  cpuidle_enter+0x12/0x14
2021-04-26T14:52:18.044348+03:00 nimbustor kernel: [15004.987945]  do_idle+0x15c/0x1ce
2021-04-26T14:52:18.044367+03:00 nimbustor kernel: [15004.987947]  cpu_startup_entry+0x1d/0x20
2021-04-26T14:52:18.044373+03:00 nimbustor kernel: [15004.987951]  start_secondary+0x119/0x11d
2021-04-26T14:52:18.044377+03:00 nimbustor kernel: [15004.987953]  ? set_cpu_sibling_map+0x440/0x440
2021-04-26T14:52:18.044379+03:00 nimbustor kernel: [15004.987957]  secondary_startup_64+0xa5/0xb0
2021-04-26T14:52:18.044381+03:00 nimbustor kernel: [15004.987959] Code: f4 75 bd eb 35 48 89 df c6 05 70 90 a1 00 01 e8 4b 07 fe ff 44 89 e1 48 89 c2 48 89 de 48 c7 c7 04 7f ea 81 31 c0 e8 14 ce a1 ff <0f> 0b 48 8b 83 f0 01 00 00 48 89 df ff 50 78 48 63 bb 60 04 00
2021-04-26T14:52:18.044398+03:00 nimbustor kernel: [15004.987988] ---[ end trace 920afba4643464d5 ]---
2021-04-26T14:52:21.779926+03:00 nimbustor kernel: [15008.900231] r8125: eth0: link up


Какого либо специфичного софта не имею. Установлен и активно используется Virtualbox, PLEX и Transmission.
maksmedia
 
Сообщения: 5
Зарегистрирован: Пт апр 09, 2021 9:00 pm

Re: Network lan was plugged in

Сообщение setsempron » Пн апр 26, 2021 6:24 pm

Вполне вероятно из-за драйвера падает сетевой интерфейс под нагрузкой. Видимо проблема вылезла после обновлений ADM. Тут мы бессильны. Дело за ASUS.
AS3202T
RT-AC68U
setsempron
 
Сообщения: 613
Зарегистрирован: Сб дек 16, 2017 8:46 pm
Откуда: Беларусь

Re: Network lan was plugged in

Сообщение maksmedia » Ср апр 28, 2021 10:29 pm

Отключил на время Transmission - за сутки ни единого разрыва... Продолжаю наблюдать.
maksmedia
 
Сообщения: 5
Зарегистрирован: Пт апр 09, 2021 9:00 pm

Re: Network lan was plugged in

Сообщение setsempron » Чт апр 29, 2021 8:11 am

maksmedia писал(а):Отключил на время Transmission - за сутки ни единого разрыва... Продолжаю наблюдать.

Вот вы и снизили нагрузку.
А что техподдержка?
AS3202T
RT-AC68U
setsempron
 
Сообщения: 613
Зарегистрирован: Сб дек 16, 2017 8:46 pm
Откуда: Беларусь

Re: Network lan was plugged in

Сообщение VasiliyM6 » Чт апр 29, 2021 8:57 am

Я не стал следовать рекомендациям саппорта из моего тикета - они предлагали подключить NAS напрямую к компу. Но мне не нужен внешний диск к компу, мне нужно сетевое устройство. Но я отказался и от uTorrent, и от qBittorrent. Вместо них перешел на "родной" Download Center. И с ним действительно пропали эти отвалы сети, и он вроде нормально качает/раздает, плюс есть возможность подложить ранее скачанные файлы через ассистент. Ну то есть я хочу сказать, что нагрузка на сетевой адаптер как бы не уменьшилась, но может "родные" приложения более правильно используют встроенные устройства и не вызывают конфликтов/проблем.
ASUSTOR AS5304T
HDD (2*WD30EFRX+ST3000VN007) in RAID 5 + WD40PURZ in MyArchive mode
+4 GB RAM KINGSTON VALUERAM KVR24S17S6/4
UPS Ippon Black Basic 650 EURO
VasiliyM6
 
Сообщения: 23
Зарегистрирован: Пн мар 29, 2021 8:33 pm

Re: Network lan was plugged in

Сообщение setsempron » Чт апр 29, 2021 5:56 pm

VasiliyM6 писал(а):Ну то есть я хочу сказать, что нагрузка на сетевой адаптер как бы не уменьшилась, но может "родные" приложения более правильно используют встроенные устройства и не вызывают конфликтов/проблем.

Нагрузка. Здесь не имеется ввиду насколько занят канал по скорости, а скорее его широкополосное использование.
AS3202T
RT-AC68U
setsempron
 
Сообщения: 613
Зарегистрирован: Сб дек 16, 2017 8:46 pm
Откуда: Беларусь

Re: Network lan was plugged in

Сообщение VasiliyM6 » Чт апр 29, 2021 8:12 pm

Я не очень понимаю, что есть "широкополосное использование" сетевого проводного одаптера. Дял меня раньше "широкополосное" было применимо только в радиопередающим устройствам. Но я не сильно разбираюсь в сетевой тематике. Для меня похоже проблема решилась. При том что ни скорость раздачи/скачивания, ни способ использования устройством не поменялись. Я по преженму качаю/раздаю торренты и одновременно смотрю видео с NAS по сети.
Но явно что то не то с сетевой подсистемой в моем NAS. Другая проблема с сетью пока не решилась viewtopic.php?f=5&t=3817
Я отключил EZ-Router, как Вы мне там рекомендовали, и врод стало получше, но сегодня поймал эту ситуацию - поменял номер порта на NAS для https, и всё - аппарат стал недоступен через Web-службы, только через telnet.
А судя по логу dmesg интерфейс сетевой как раз начал "прыгать", хотя по ssh я зашел и перегрузил NAS. На эту тему отельный тикет у поддержки есть (https://support.asustor.com/index.php?/ ... View/40750).

[32777.048058] traps: streamer[30852] general protection ip:7fab662622dd sp:7ffe23f11770 error:0 in libc-2.22.so[7fab661ec000+194000]
[52719.647456] traps: streamer[28024] general protection ip:7fab662622dd sp:7ffe23f11770 error:0 in libc-2.22.so[7fab661ec000+194000]
[80133.244940] r8125: eth0: link down
[80143.557589] r8125: eth0: link up
[80161.981178] r8125: eth0: link down
[80166.149628] r8125: eth0: link up
[80175.357014] r8125: eth0: link down
[80186.693583] r8125: eth0: link up
[262125.752410] utility[19039]: segfault at 10 ip 000000000040930d sp 00007fff4afc1cc0 error 4 in utility[400000+8e000]
[324102.874625] lighttpd[19574]: segfault at 0 ip 00000000004188d1 sp 00007ffce38762f0 error 4 in lighttpd[400000+2d000]
[686028.206811] lighttpd[19561]: segfault at 8 ip 000000000040b2c7 sp 00007ffce3876200 error 4 in lighttpd[400000+2d000]
[734916.229142] r8125: eth0: link down
[734918.349797] r8125: eth0: link up
[734936.772914] r8125: eth0: link down
[734940.877642] r8125: eth0: link up
[734950.085192] r8125: eth0: link down
[734961.357583] r8125: eth0: link up
ASUSTOR AS5304T
HDD (2*WD30EFRX+ST3000VN007) in RAID 5 + WD40PURZ in MyArchive mode
+4 GB RAM KINGSTON VALUERAM KVR24S17S6/4
UPS Ippon Black Basic 650 EURO
VasiliyM6
 
Сообщения: 23
Зарегистрирован: Пн мар 29, 2021 8:33 pm

Re: Network lan was plugged in

Сообщение setsempron » Пт апр 30, 2021 7:32 am

У кого-нибудь остался системный журнал хотя бы за полгода? Там можно посмотреть с какой версии прошивки начались отвалы сети.
AS3202T
RT-AC68U
setsempron
 
Сообщения: 613
Зарегистрирован: Сб дек 16, 2017 8:46 pm
Откуда: Беларусь

Re: Network lan was plugged in

Сообщение KPOTOC » Чт май 06, 2021 8:48 am

Столкнулся вот и я с этой проблемой...
Мой AS6208T был в связке с ASUS RT-N12C1, между ними стоял тупой с гиговыми портами, сколько прошивок за 2 года сменилось и проблемы этой не было, весь локальный трифик через гиговый ком был, инет ясное дело через N12, между делом канал нагрузить на роутере в мах не было реальным, так как провайдер 80 дает...с настройками особо не заморачивался, белая статика, нас в dmz, ez включен, трансмейшн, стоковый, торрент, все работало, несколько виртуалок... пришлось физически переместить нас на другую локацию, тот же провайдер, но там стоял rt-n10e да еще и не с последней прошвой, на 12с1 была стоковая последняя, и началось, выключал ez, dmz, upnp, приложухи отключать, максиму чего добился того, что хватило поднятого eth на 20 минут, пришлось в эту локацию ставить прошлый роутер, и проблему как рукой сняло, на rt-n10e у меня падал не только eth на nas, у меня падала как локалка так и инет, наглухо убивало роутер... Как доберусь в локацию я конечно посмотрю как это внутри выглядит, удаленно трудно такие вопросы понимать... Какие то косяки с маршрутами/адресацией...
Пост я больше пишу для того, что бы было понятие, что косяк не только в прошивке, а во взаимосвязи прошивки нас и роутера, и то грешить на нас можно после того как почитать логи на прошлых прошивках...
AS6208T + AS-RC10 + Logitech Keyboard K400 + Rii i25A
DDR - 16Gb (2x8Gb)
SSD - Intel 80Gb (SSDSC2BB080G401) Volume 1 (один)
HDD - WD 3Tb Red (WD30EFRX) x 2 Volume 2 (RAID1)
HDD - Seagate 3Tb (ST33000650NS) x 2 Volume 3 (RAID1)
KPOTOC
 
Сообщения: 190
Зарегистрирован: Вс июл 16, 2017 6:49 am
Откуда: Донецк / ДНР

Re: Network lan was plugged in

Сообщение VasiliyM6 » Чт июн 10, 2021 9:33 am

Сегодня, а точнее вчера вечером, опять какая то хрень произошла. Но уже новая. Смотрели фильм с NAS через UPnP Media Server. Downloader Cenetr качал/раздавал торренты. Внезапно NAS пропал из сети. Причем и через SSH не доступен. Перезагрузка не помогла, перевтыкание сетевого кабеля в другой сетевой разъем не помогла. Вспомнил про WiFi адаптер USB. Через него получилось зайти по IP адресу этого WiFi. На LAN порта показывал какие то странные адреса 169.*.*.*. И по одному и второму разъему. То есть LAN порты отрубились, работал только WiFi свисток.Вроде NAS стал доступен и я пошел спать, ибо уже час ночи был. С утра все работало как обычно - LAN ожил, как будто ничего и не было. Что это было - непонятно.
ASUSTOR AS5304T
HDD (2*WD30EFRX+ST3000VN007) in RAID 5 + WD40PURZ in MyArchive mode
+4 GB RAM KINGSTON VALUERAM KVR24S17S6/4
UPS Ippon Black Basic 650 EURO
VasiliyM6
 
Сообщения: 23
Зарегистрирован: Пн мар 29, 2021 8:33 pm

Пред.

Вернуться в Всё про NAS

  • Вы не можете начинать темы
    Вы не можете отвечать на сообщения
    Вы не можете редактировать свои сообщения
    Вы не можете удалять свои сообщения
    Вы не можете добавлять вложения
  • Кто сейчас на конференции

    Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3

cron